A couple of issues with the the Transcribe (beta) mode

(This appears to be in only some languages. I see it in Italian but not German.)

I’m not sure how I feel about this one yet. I think needing to type out a sentence (from listening mode) is a pretty useful addition to the arsenal, despite me being one of the strongest advocates for speaking mode.

(From vocabulary mode, I would say that it’s less useful because you would have to be doing All Translation All The Time. This is one of the things that I loathe about DopeyLingo; it thinks that the way to learn to speak a language is to constantly draaaag you back to English, always English, by translating, and more translating. In Vocabulary mode for a STANDARD (single word) cloze, you can work out the missing word from context, usually, mostly. However for a full transcription in Vocab mode the only thing that you would have to go on is the English translation. True, you can still hear the audio with [Ctrl]+[Space bar], but in that case you may as well be doing it as a listening exercise, not a vocab one.)

I’m not so sure about the need to match the capitalisation and punctuation EXACTLY though. I can see both sides of that argument. The first couple that I tried were “wrong” not because of the words but because of an omitted comma or full stop.

Which brings me to a key issue.

I turned on the English translation on the one shown below for illustration purposes. Previously I had heard the audio and knew that this was in Lei form, not tu form and that the first word was thus È, not Sei.

BUT… while there are buttons below the input box to input accented characters, they are lower case only. And as noted above, Transcribe Mode DEMANDS that both case and punctuation match. So when I click that button, this is the input:

Big, glowing red, telling me that the input is wrong.

The only way around this is if you know dead keys or alt keys syntax by heart. In my case I’ve typed [Alt]+[0200] so many times that I know that it’ll get me È, but that may not be the case for new learners.

Another issue is that the buttons show [Alt] keys as shortcuts for the accented characters; [Alt]+[E] for both of the accented E characters. [Alt] rarely works in a web browser because it’s bound to menu keys. In Firefox if you type [Alt]+[E] you’ll just get the edit menu, in Chrome you’ll get the Customise menu pop up.

Another issue is that it would probably be best to remove the proofing language from the input text box. It seems to be expecting English, so if you enter any other language (and obviously you will) you end up with more red squiggles than a paint factory with a leaking red paint vat.

But for all that I should add… thanks for keeping the site moving with new features. It is indeed appreciated.


I’m also not a fan of the new translation feature. There are too many different ways to say things to know which one it wants. Maybe instead of a full translation, they could put multiple blanks in the target language sentence, and you have to enter in the complete sentence, still in the target language.

Also, if you go into your settings on your computer, you can add the Italian keyboard so you don’t have to use the alt codes or CM keyboard shortcuts anymore. I’ve got like 5 keyboards on my laptop that I just cycle through using alt+shift.


I have been advocating a “Full sentence mode”, but I envisioned it as a mental exercise, where you would be presented with a sentence to translate, which you would translate in your head. Then, after a key press, you would compare it with the suggested translation and judge whether you passed or failed the challenge.

This, on the other hand, is cumbersome and slow. I’m sorry, but I don’t think I’m going to use this mode, not its present form. I like the visualization of the words and the spaces though; that helps in choosing between different forms of expressing the same concept.


I found this “Transcribe” mode useful only for my listening practice. I won’t use it for my vocabulary practice for the same reason as @cdemora mentioned. – Too many possible answers.

Duolingo also offers the full sentence mode for the vocab practice, and many Duolingo users complain about the narrow acceptance of possible answers. Some lessons have 1,000+ possible translations per sentence. If you are a PRO user, you can manage the single cloze mode by adding alternative answers yourself, but it’s almost impossible for the full sentence mode. For example, there are 24,8026 ways to translate “I love you” from English to Japanese (source) :smiling_face_with_tear:

However, I would love to use the transcribe mode for the listening skill. Dictation is one of my favorite approaches on Duolingo. It’s particularly useful when a target language has a quite different system of word order. Dictation lessons enable me to shut off my brain processing in English, and to understand a sentence in my target language.

I would like to propose @mike to insert a small “help/hint” icon next to the “Transcribe” mode in order for users to understand how to utilize this new mode. Or hide the Transcribe mode when the Vocab skill is selected.

I also hope the new mode accepts answers without a “period” (.) at the end of each lesson. For the first time I played in the Transcribe mode, I didn’t understand why my seemingly correct answers were rejected.

Capitalization is another problem – some sentences from Tatoeba are not so accurate in capitalization, especially in Indonesian (my target language). “Anda” (meaning “you”), for example, should be always capitalized even in the middle of the sentence so as “I” in English is. But, roughly speaking, half of the sentences from Tatoeba do not follow the rule. I added the correct spellings in the alternative answers field, but they are not accepted by the Transcribe mode.

1 Like

Thanks for all the feedback! This is all super helpful. :slight_smile:

Capitalization should now be optional, punctuation is still required though. Will need to give some more thought to punctuation - all or none is fine, but it gets tricky trying to check for some punctuation, if that makes sense.

Pressing shift and clicking the accented character button should add the capitalized version. The shortcut keys could indeed use some updates due to browser conflicts, the best option is to change your keyboard layout if possible.

Nice catch - thanks! Removed.

Interesting! I’d also been thinking about playing cloze sentences as a mental exercise where you’d see the sentence, then tap to see the answer, then tap to indicate you got it correct or incorrect. Perhaps a correct answer would be worth just 1 point, and the idea would be it’s a bit faster than text input and there’s no distraction or obvious answers with multiple choice.

We thought this would be the likely feedback :slight_smile: and have left just the transcribe option available for now.

Good point - we’ll have to get alternative answer support added, though that field is meant only for alternative clozes, so it wouldn’t be of help for other words in the sentence. We’ll have to give some more thought to how best to handle that case, it may be copying the sentence to a custom collection is the way to go for now.