The hint in the transcribe mode wipes out answers

This glitch occurs only in the transcribe mode on the iOS app.

I tapped the hint icon (the question mark icon) in the middle of a sentence. The system didn’t return the expected letter. Instead, it wiped out my typed answers and forced me to retype from scratch.

If I tapped the hint icon again for the same word, it worked properly for the second try.

Attached are screenshots for your reference.

CASE 1

  1. Typed in the first four words, and was stuck with the second letter of the fifth word.
  2. Tapped the hint icon, and the screen didn’t return the correct letter “a” for “jalan”. Instead, it gave me the first letter of the first word only and wiped out the rest.
  3. Typed in for the second time, and tapped the hint icon again.
  4. The screen returned the correct hint “a” this time.

Image 1:

Image 2:

Image 3:

Image 4:

CASE 2

  1. Tapped the hint icon for the last letter of the third word.
  2. Wiped out all words except the first letter of the first word.
  3. For the second try, I typed in from the beginning to the fifth word without hint. And I used the hint for the second letter of the sixth word.
  4. Partially wiped out. Rolled back to the second letter of the fifth word (Boston).
  5. For the third try, I typed in all words except the last three letters of the final word.
  6. Tapped the hint icon three times to get the last three letters. The system returned the correct three letters. But the result was judged “incorrect” in red color when I tapped the “submit” button…

Image 1 for Case 2:

Image 2 for Case 2:

Image 3 for Case 2:

Image 4 for Case 2:

Image 5 for Case 2:

Image 6 for Case 2:

Device: iOS 15.5 on iPhone SE2 and 6S
Clozemaster app: version 2.8
Course: Indonesian from English (note: both languages use only 26 Latin alphabets. No accent letters like French.)

1 Like

CASE 3

As explained in CASE 2 of my previous post, the system partially rolls back to somewhere in the middle of sentence. Here is another similar case for your reference.

I filled in the first nine words on my own. But my iPhone on-screen keyboard doesn’t have the franc symbol. So I tapped the hint icon to fill in. And then, my answer was rolled back to the first letter of the third word (Prancis = France).

I guess the partial rollback occurs 1) when the already filled-in answer is long enough, or 2) to the point where a letter is capitalized. — in Case 2, “Boston” (not “boston”) and in Case 3, “Prancis” (not “prancis”).

1 Like

Thanks for letting us know and sorry for the trouble! Looks like the hint is case sensitive like you suggested, so while the color hint is not case sensitive, when you tap the hint button, it goes back and checks each letter of the input so far and if the case doesn’t match, it says “ok the input is correct up to this point” and wipes out everything after that. We’ll have a fix included in the next update :+1:

1 Like

@mike
Thank you for your response! I found another glitch related to the transcribe mode on iOS.

I filled in a double or a single quotation mark from my iPhone on-screen (default) keyboard. But they are recognized as different characters and rejected. A period and a comma are totally fine, though.
Just in case the original sentence might be written in a different ASCII code, I edited the sentence in my personal collection, and then tried the second round. But the system kept returning the error judgement (turn the sentence in red).
I don’t have this issue on my laptop browser version. It’s only on iOS.

So, I had no choice but to use the hint icon in order to fill in a double or single quotation mark. And then, the same rollback wiped out the whole answer…