Radio Timer not working properly

The brand new timer feature in Clozemaster Radio isn’t working for me: the timer is paused as soon as the device goes into standby mode. This means that even if I have the Radio function play sentences all night, the timer will never count down to zero, unless I keep the screen lit all the time.

How to reproduce:
0) Start Clozemaster Radio on a collection of your choice.

  1. Start a timer for 1 minute.
  2. Verify that the timer is counting down, and note the current time left.
  3. Put the device in standby mode.
  4. Verify that the voices are being played.
  5. Wait one minute.

Expected behavior: The voices should stop playing after about a minute.
Actual behavior: The voices keep on playing long after one minute. Wakening the device, you will see that the timer has only counted down a few seconds.

App version: 2.8
Device: Moto g(7) power, Android 10

5 Likes

I’m seeing the same thing.

In addition to that it took a LOT of attempts to get the sentences to start playing after I set the timer.

4 Likes

I have recently found a related glitch on my iOS app (the latest Clozemaster version 2.8.1 installed in September). I set the timer at 15, 20, and 30 minutes in a three-night row and fell asleep. The app didn’t turn off the radio mode and kept running at least for two hours even though the timer has already gone down to zero. I had to manually turn off the radio mode.

I don’t remember I had the same glitch with version 2.8.0 or below.

The OP (morbrorper) reported it under the Android bug section. Maybe I should’ve done separately as an iOS bug if the developers of iOS and Android apps are different entities.

I wish this could get fixed soon. I find myself waking in the middle of the night hearing strange voices in my bedroom. :scream:

I think it should be quite easy to implement correctly: just take note at the beginning, of the time (and the date!) when the time should be up, and check against that at the completion of each cycle. Just counting the screen time won’t do, as there will be very little of that even during a long session.

@mike: are you listening? :slight_smile:

1 Like

Work in progress, thanks for letting us know.

2 Likes

I notice with great satisfaction that the timer is now working, in version 2.9.9.1 on Android. :slight_smile:

1 Like