Polish text input on Mac buggy with alt shortcuts

I’ve tried submitting this a couple of times as a bug report but I’m not sure I explained it clearly. Let me try here with a longer explanation.

There are major problems if you do the following things together:

  • Study Polish from English
  • Use a web browser on a Mac
  • Use Text Input

There are problems no matter whether you use the native Polish (Programmers) keyboard layout, or if you stick with English and use Clozemaster’s “Accent Shortcuts”.

1. Accent shortcuts broken with double letters

Keyboard Layout: Any (Polish or English)
Accent Shortcuts: Enabled
Shortcut Hotkeys: Enabled

Let’s try to type the word dość.

d
o
Hold down the Option key
s
c
Let go of the Option key

Result:
image

The ć overwrites the ś instead of being appended.

2. Impossible to type Ś with Shortcut Hotkeys on

Maybe we try to to avoid bug 1 by using the native Polish keyboard?

Keyboard Layout: Polish
Accent Shortcuts: Disabled
Shortcut Hotkeys: Enabled

Now we try to type dość using the same key sequence as above.

Result:
image

The ś is never typed at all!

3. Shortcuts trigger at the wrong time when word answered wrong

Okay let’s turn Accent Shortcuts back on and type carefully when we have sequences like ść.

Keyboard Layout: Any (Polish or English)
Accent Shortcuts: Enabled
Shortcut Hotkeys: Enabled

Oh no, I guessed a word wrong.

image

Okay before I move on I will practise retyping byłaś.

b
y
Hold down the Option key
l
Let go of the Option key
a
Hold down the Option key
s

  • what wait?

I’m just trying to type ś but it’s triggering the sentence search feature!

4. Shortcut settings are too coarse

Okay whatever, we never use these fancy shortcuts anyway. Let’s turn them off.

Keyboard Layout: Polish
Accent Shortcuts: Disabled
Shortcut Hotkeys: Disabled

Result… I’m stuck here. I can’t press Enter to move on to the next word any more, because Enter counts as a Shortcut Hotkey!

image

Now I need to move my hand from the keyboard to the mouse to click the button after every guess. :frowning: Obviously I do not study so much Polish this way as I will get RSI very quickly.

How to fix

Typing Polish answers is very frustrating at the moment. It would be great if it could be fixed comprehensively, but if this is hard, there is a much easier way.

  • In Settings, allow us to use Enter without having to enable all of the other Alt+Something Shortcuts.

If I had this option, then I could do:

Keyboard Layout: Polish
Accent Shortcuts: Disabled
Shortcut Hotkeys: Disabled
Enter Shortcut: Enabled

And everything would be okay! Thanks for reading this far. I know this is a long and complicated gripe.

1 Like

Interesting that you say this because a couple days ago, for whatever reason, I could not type ą in the cloze input! Very odd. I was using the Polish programmer’s keyboard in Brave. I don’t think I’ve ever been able to type ść without pressing and releasing the option key once for each letter, but I don’t think I’ve encountered the enter key issue, except in the app on an iPad with a keyboard. I’ll grant that’s probably because it’s a tablet app, but I really wish it could work like a normal web form because there you can type ść, ęś, ąć, etc. pressing the option key only once! I’ve ended up speaking a lot of my answers into my phone to get around the cumbersome typing. :slight_smile:

1 Like

Thanks for the thorough feedback!

This should now be implemented - could you please let me know if it’s not working as expected / you notice any other Polish input issues?

2 Likes

Thanks Mike - just did a test on Mac/Safari. Issues 1-3 continue as described but I see your change that the Enter key works even if shortcuts are turned off. This combo is now perfectly good for learning on Mac. :+1:

2 Likes