Auto-inserted "English Translation" tag is removed after edit

Once you click the “forum icon” during a lesson to post a comment on a sentence discussion, the English translation of the target sentence is automatically inserted like this: [details="English Translation"]A police station is close at hand.[/details]. You can add your own comment after the translation field.

After submitting a comment, you can see the “edit” link located below your comment to further modify on the same page. But the “edit” link erases the auto-inserted translation tag [details="English Translation"][/details] as well as a linefeed code. As a result, the translation field is expanded and integrated with the context of the comment.

This is an example. I posted it from the lesson page, and edited it on the same page by clicking the “edit” link.
The first sentence – You should emphasize that fact.– is the English translated automatically inserted by Clozemaster. And the translation tag is now removed and expanded. I haven’t figured out the conditions, but sometimes the edit counter (the pen icon) goes up, but sometimes not.
This possible bug happens only when editing via lesson pages. If you go to the forum > sentence discussion and edit your previous comment, the translation tag remains.
I found the same possible bug on mike-lima’s post as well. So, it’s probably not related to my system settings (Win10 + Chrome).