Having Searched "Speaking option"

And read a note from Barcarolle, may I ask some advice on how it works, per favore. I work mostly on a Samsung tablet, presumably chrome, I click on Record and say the missing word or the whole sentence but nothing happens. Would really like to use this option. Thanks in anticipo…

1 Like

I only use it on Chrome on desktop, where it works a treat, but I could imagine perhaps you might have microphone permissions blocked for your browser on your tablet or such?

Do you get any error message? Does clicking the button fail?

As soon as I click it, it turns into “Recording” and listens for any input. As soon as it doesn’t detect further input, it automatically switches off and detects the cloze and marks it as solved if correct.

Record option on mouse-over:

After pressing it:

After completing the speech detection:

Let me give it a go on my mobile.

1 Like

Ok, I have tried it on my Android mobile, but I keep getting errors, so I’m not sure what could be happening on your Samsung tablet, but I unfortunately also can’t seem to use it in any way whatsoever on mobile.

I tried Chrome and non-Chrome. I tried the mobile web version and desktop web version on mobile. I tried with and without browser microphone permissions. I’m afraid I can’t reproduce being able to click but nothing happening. I just keep getting the “it’s an experimental feature which works best on Chrome desktop” pop-up (also on Chrome), or (only on Chrome) a notification stating Clozemaster requires microphone permissions and asking whether to enable.

1 Like

Sindaco, mille grazie, sei molto in gamba! At least I’m “doing it right” which is good. I really appreciate all your info and testing and will do some checking on permissions etc.

Meantime, tutto va bene otherwise;-)

1 Like

I just want as many people as possible to be able to use this wonderful feature :smile:

Sadly no luck, but let me throw in some extra info, in case Mike can use it in any way.

I only have a limited set of devices to test this on, actually, I’ve just realised I could borrow a tablet to check on too, so I’ll get back with that later, in case it makes any difference (though likely not a Samsung I believe, sorry).

I tested on Android Pie, with the following Chrome version:


Here I kept getting the following error, even when having allowed permissions either globally from the settings, or through the pop-up prompt, when ensuring I was on the desktop version:



Even refreshing, logging in again etc. could not get it to work.

Then I tested it on Android 11, with the following Chrome version:

photo5913630544925669370 !

And depending on whether I gave Chrome mic permissions when in use or chose to ask every time, I got the following errors, neither of which ended up allowing me to use the feature in the end:



Where I just ended up getting stuck in a loop of Chrome asking for permissions and saying it was not able to set it, despite globally already having given Chrome the permissions from the system settings.

Bit of a mystery.

1 Like

@sindaco. Read with interest. Have tried it on my Lenovo computer, no joy, and again on my android tablet having checked all permissions, sound etc. Perdindirindina you have worked hard for us!

Ma sì sì un mistero no? Allora, back to Listening and learning lots more.

Stammi bene il mio ricercatore!


Perdindirindina, imagine, I only just learned of this word’s existence earlier today!

For the moment the mystery remains, but I do recall well I did indeed have to switch to Chrome even on my desktop in order to be able to use the Speaking option for reviews, it wasn’t working for me in any other browsers.

1 Like

Thank you sindaco! I wandered around muttering perdindirindina for hours, thinking it was impossible, and suddenly it just happened! Bingo!

Addirittura! is my other favourite. (The young Montalbano said it twice last week as he solved more crime in Vigata!)

1 Like